Pingbacks – An Update

I did rant a bit on my blog when things weren’t working. So it is only fair that I update it now that it is fixed.

So yeah, pingbacks did start working for me since Saturday morning. Yay!!! For some reason, when I did post my WPC challenge post on Friday night, the pingback failed to show up in the Daily Post (DP) page. So I went back to this forum topic and updated the same. One staff from WP (I did get her name wrong in that topic. Very bad of me, but in my defense I was sleep deprived and was woken up by a bad dream just a few minutes ago and couldn’t get back to sleep) helped me check it out. So I tried it on my other blog post and in the second try (because I made my first post private) it appeared in the DP page. Hurray!!! So I went back and updated my WPC entry with the proper https link for the DP page. Nope, nada, zilch. No pingback. Didn’t work. I was super pissed about it. Then because I am used to debugging these kind of stuff at work, I went and compared the settings in both the blogs. And found one section which was unchecked in this blog which was checked in the other one from where the ping back worked. So I checked that option and to be sure, submitted one more entry and Hurray!! got the pingback from this blog for the new post too on the DP page. But as Software Engineer, we don’t rely on one or two successful runs. We need to monitor it for a while to see it passes all scenarios. So I had one more to check. I did write my SoCS post and then as usual linked it to Linda’s post waiting for it to be published and see if the pingback to my other post and to Linda’s worked or not. Just to make sure that it isn’t only the WP’s blog its working (make sure to cover all the usecases here). And it did work and I didn’t have to manually make an entry.

In case your pingbacks are still giving trouble, here is one setting which I think might help you. You can find it in ‘Setting’s at tail end of the left hand side ‘of ‘MySites’ section of your new UI of WP. wp1

Make sure you have checked both these options and then try it with a new post. For me updating an old post after this change, didn’t show any effect, but honestly, I didn’t spend much time to test it elaborately. Hope all of you, who had pingback issues, got it working now. If not, please update that forum topic so that the WP staff can check it out.

Happy Blogging to all.

No pinging back

Pingbacks – sounds like a simple thing doesn’t ? Just copy paste a URL of any WordPress site in your post either as a link or a text and you should be able to see your post having that link in the original post. But seems like mine hasn’t been working lately. I didn’t even notice it until I posted the Friday’s Weekly Photography Challenge response post and it didn’t show up in the comments or the article section of the Daily Post website. On checking further it seems like the previous week’s entry is also missing (I was wondering about it when I had very less visits because those are the ones that garner more attention in my blog). Not only there, even the entry to Linda’s Stream of Consciousness Saturday prompt went missing, when I never had a problem getting it listed in her site. I checked with a WordPress staff and they said they will check it out. But I am not sure how and when it is going to be fixed 😦 because there seems to be so many people facing the same issue.